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Program Description
Drag And File streamlines and simplifies the work of managing files on your computer. It offers several 
unique functions, such as a directory finder and a duplicate file finder.

Drag And File works at several levels of sophistication and integrates with other management and utility 
programs. The result is an uncommon degree of flexibility: Drag And File can be configured to meet your 
needs, your working style, and your experience. When you need more, Drag And File delivers. 

Unlike most other Windows file managers, Drag And File allows you to highlight individual files and tag 
multiple files, which makes possible batch operations on non-contiguous groups of files. 

Drag And File offers a broad range of file management tools:
Drag-and-drop file move, copy, and delete
Viewing of all text and most graphics files
Tree and branch batch operations on all files
Single click execution of most frequent tasks (including viewing) from a toolbar 
Separate windows for each drive
Full hot key control for hands-on keyboard execution

Main window

Drag And File displays a window complete with toolbar and menu choices for each drive selected. You 
may open up to 12 drive windows simultaneously. 

The entire program can be run from a single small Drivebar which floats unobtrusively on your screen. 
The Drivebar makes complete directory and file information just a mouse click away.

Drivebar
Drag And File includes an Uninstaller to remove the program and changes made during installation. 

Note:  Microsoft Windows' file-handling requirements may make it necessary for you to delete
the uninstaller file itself. 



User Help: Guides and Resources
Drag And File is designed to present options and procedures clearly. The window components, including 
icons, graphic and text buttons, and directory tree displays, make evident what to do and how to do it.

Along with ease of use and the ordinary features of file management, Drag And File offers an unusual 
degree of sophistication. In addition to the printed documentation several kinds of resources are available.

Related Topics:
Online help
Telephone and other wire help
Uninstall



Online help
This online help system is available at any time by clicking on the Help menu on the menu bar in the main
window. Context-sensitive help is also available for most menus and dialog boxes. For information and 
procedural help specific to a screen or menu, click on the Help button.



Telephone and other wire help
Canyon Software is committed to producing software that is useful and productive. To help users make 
full use of Drag And File, Canyon Software maintains a technical help line for registered users from 9 am 
to 6 pm Pacific Time.

Phone (415) 382-7999
Fax (415) 382-7998
CompuServe 71320,1277
America On Line DanBCan



Uninstall
To remove Drag And File:

Click on the Drag And File setup icon in the Drag and File group in Program Manager.
The setup screen appears. Follow instructions to remove Drag And File.

Note:    Microsoft Windows' file-handling requirements may make it necessary for you to 
delete the uninstaller file itself. 



Setting Preferences
Drag And File offers several ways to tailor the program to meet individual needs. 

Related Topics:
Drag And File Setup
Options/Settings



Drag And File Setup
The Setup program provides choices which allow you to install and uninstall Drag And File in different 
ways. The program installs a Setup icon in the Drag And File group window. This icon allows access to 
the Setup program to modify those choices after the program has been installed, to reinstall the program, 
or to uninstall the program.

To make changes using the Setup program:

1. From Program Manager (or whatever Windows shell you use) open the Drag And File group 
window. Double click on the Setup icon. 

2. The Installation dialog box displays.

3. Select one of the first two choices to reinstall Drag And File, with or without Fileman Launcher.

4. Select either of the last two choices to remove part or all of the Drag And File installation.



Options/Settings
From the Options menu you access the Fonts and Settings dialog boxes, which allow you to adjust 
several aspects of the program's performance and display.

To change fonts:

1. Select Fonts from the Options menu.

The Fonts dialog box displays. Available fonts are those which are installed under Windows, or 
under a type manager working with Windows.

Fonts options dialog box

2. Make whatever changes you wish and click OK.

The changes take effect immediately and remain when you exit the program.

To change Settings:

1. Select Settings from the Options menu.

The Settings dialog box displays.



Settings dialog box
2. Enter your choices for warnings, multiple windows operations, window appearance, vieweer 

options.
Overwrite Warnings. When enabled, these warnings appear when the files you are copying or 

moving are about to overwrite files of the same name. 
Multiple Window Operations. Drag And File lets you perform operations on tagged files in more 

than one window. These choices allow you to specify which operations you would like to perform in 
multiple windows.

Window Appearance. These choices follow the pattern for Microsoft Windows: cascaded 
windows are overlapped slightly, and tiled windows are fully visible.

Viewer options. Check the first of these options to view a highlighted file automatically, or the 
third option to keep the viewing window visible. The second option is selectable if the first option is 
checked.

3. In the box beneath Editor, enter the full pathname (the drive, directory, and full executable 
filename) of your word processor. The illustration shows the full pathname for Microsoft Word for 
Windows.

This information allows Drag And File to load the word processor you specify here and open a 
highlighted or tagged file when you choose Edit File from the Actions menu.

4. Click OK to save your changes and exit. Click on Cancel to exit without making changes.



Auto-configure
Auto-configure preserves changes to the next session of the program. Changes you make in the Settings 
dialog box from the Options menu or changes in the dimension of the drive windows you make by clicking
and dragging the borders are automatically saved and remain in effect as the default choices when the 
program runs again.



Drag And File Drivebar
About the Drivebar
Using the Drivebar
Configuring the Drivebar



About the Drivebar
Though small and unobtrusive, the Drag And File Drivebar can provide access to all your Drag And File 
functions.

The Drivebar consists of a floating bar containing buttons which represent your drives, removable and 
fixed drives, local and networked, and a control bar. Click on a drive button to open a new drive window. 
Click on the control bar to open a menu with choices to control the Drivebar display and to close all open 
Drag And File windows.

Drivebar
The DF Drivebar normally floats in the foreground, above whatever application is current.



Using the Drivebar
To activate the Drivebar, open the Drag And File group window from Program Manager and click on the 
DF Drivebar icon. 

Drivebar icon



Configuring the Drivebar
The    Drivebar can be altered using the Drivebar control menu.. 

To configure the Drivebar:

1. Click on the control bar in the upper left corner of the DF Drivebar.

The control menu appears.

Drivebar control menu
2. Click on Display Vertically (or Display Horizontally) to select the configuration other than 

the one currently in effect.

3. Click on Always Visible to make the Drivebar appear on top of other programs.

4. Click on Close All Drag And File Windows to close all open Drag And File drive windows, 
but leave the Drivebar icon visible.

5. Click on other choices as needed to Move, Close, open a Help window, or to see information about 
the Drivebar.



Fileman Launcher
Fileman Launcher is a utility that helps to manage all your Drag and File auxiliary programs, such as Drag
And View. Fileman Launcher is installed as an option when you install Drag And File, and a menu of its 
choices is accessible by clicking on Fmlaunch in the Drag And File menu bar.

Fmlaunch menu
Using the Fmlaunch menu you can do the following: 

Add and delete items to the list programs that Fileman Launcher runs
Fileman Launcher can run up to 12 programs with Drag And File
Change how the programs are run 
Add command line arguments to the programs
Quit all the programs 
Rerun the programs



Drag And File Main Window
The Drag And File window is divided into several functional and information sections. Drag And File can 
open up to twelve windows simultaneously.

Drag And File main window

The menu bar contains drop down menus. They are accessible with a mouse or directly from the 
keyboard by using the Alt key in combination with the underlined letter or arrow keys.

The information sections contain data about the drive currently displayed, number of directories on this 
drive, the space remaining on the drive, the    files in the selected directory, and their total size.

Note: Drive data may be incorrect for compressed drives.

The drive buttons allow you to choose which drive information the open window displays. Double clicking 
on the icon of the currently displayed drive opens a second window displaying that drive.

The lower half of the window is divided into two panes: information in the left pane concerns directories, 
and information about files appears in the right pane.

Related Topics:
Choosing files and directories
Menu Bar
Drive bar
Toolbar
Directory pane
File pane



Choosing files and directories
Drag And File, unlike other file managers, allows you to select and work with directories in the same way 
that you select and work with files.

Drag And File marks files and directories by highlighting, tagging, and dotting.
Highlight files and directories by left clicking on them with the mouse or by using the arrow keys 

to move the highlight bar up or down over a listing. Only one directory or file can be highlighted at a time. 
Operations like Copy or Move can be performed on a highlighted file by clicking the appropriate tool, or by
using drop down menus or keyboard shortcut keys. If any files are tagged, highlighting is ignored.

Tag and untag files or directories by several methods:
Right click with the mouse to tag and untag; Shift-Left click to tag contiguous groups of files or 

directories.
Right arrow to tag; left arrow to untag.
Spacebar and Ctrl-Right click to toggle tagging on or off.
Dots mark files which have been copied. Dotted files may be reselected as a group for other 

operations.



Menu Bar
The menu bar contains the headers for the main drop down menus. Most menus include information 
about shortcut key combinations to activate commands from the keyboard.

Drag And File includes in its menu bar extensions¾drop down menus inserted in the File Manager's menu
bar by utility and other programs. Examples include the Stacker file compression program, and the 
Microsoft Backup, AntiVirus, and DoubleSpace programs.



Drive bar
The drive bar includes buttons that represent all accessible drives. 

Double click to the right of the drive buttons to open a dialog box in which you choose another drive 
window to open.

Drive selection dialog box



Toolbar

The toolbar displays a series of buttons that activate tools or shortcuts.



Directory pane
The directory pane displays, in a tree format, all directories and subdirectories of the currently selected 
drive.



File pane
The file pane displays a list of the files and their attributes contained within the currently selected directory
or subdirectory.



Search function

To locate a specific directory or file, when the appropriate pane is active, start typing the name of the 
directory or file. Your typing appear in a small window that opens over the directory count in the lower left 
corner of the window, beneath the directory pane. As you type, the highlight bar will move to the directory 
or file which most closely approximates your typing.



Drag and drop functions
Drag And File uses all the mouse conventions associated with Microsoft Windows programs.
When you drag and drop files and directories to a directory or drive button, a dialog box opens. Using 
options in the dialog box you can specify a Copy or Move operation, the name of the file or directory, and 
use a browse feature to specify the path.



Toolbar functions
Drag And File's toolbar contains buttons which make the most common file management tasks easily 
accessible.

Toolbar

Related Topics:
View functions
Toolbar buttons



View functions

 The View button differs from the other buttons on the toolbar: it opens a view window with its 
own toolbar. The view window and toolbar buttons vary according to which pane (directory or file)    was 
active when the View button was pressed. In addition, if the file pane was active, available buttons in the 
viewing window depend on what kind of file was highlighted or tagged.

Related Topics:
Directory view
File view



Directory view
If the directory pane was active, the View button opens a list window to view an alpha ordered list of files 
contained in the highlighted directory or in the tagged directories. 
The toolbar in the Directory view window replaces the New button with a unique Dupes button:

Lists only duplicate files in the highlighted or tagged 
directories. This function allows you to search a 
directory, a branch, or a whole drive for duplicate files. 
When this function is active, the words Duplicate Files 
appear in the search window in the lower left section.

File view
If the file pane was active, the View button opens a Drag And View window to view the contents of the 
highlighted file or the first of several tagged files. The view window uses viewers to display files in native 
format, or in a form as close as possible. Drag And View will also display readable files in ASCII format 
and any file in its hexadecimal format. In addition, Drag And View plays sound files (those with a .WAV 
extension).

Drag And View Toolbar

For further information on Drag And View functions, see Drag and View.



Toolbar buttons
Opens a view window to see a list of files in 
selected directories or a Drag And View window to
view the contents of selected files.

Copies a file. The file may be renamed as part of 
a Copy operation if you type the full pathname of 
the new file in the text field in the Copy/Move 
dialog box.

Movies a file. 

Deletes a file. The dialog box lets you confirm the 
operation.

Renames a file.

Opens a new drive window. Up to 12 windows 
may be open at the same time.

Filters the filelist to display only files with the 
attributes and characteristics you specify. The 
attributes may be saved as the default.

Prints a file or directory list. 

Makes a new directory as a subdirectory of the 
currently selected directory.

Zips one or more files into a single file using 
PKZIP. If the operation generates an archive file 
larger than the storage medium, you will be 
prompted to use additional media if you are using 
PKZIP v. 2.04g.



Using the Keyboard
Drag And File allows you to access most functions directly from the keyboard by using a 
combination of Alt keys to open menus and select commands. You can, of course, use also 
use the mouse to select functions from drop down menus.



Search
Drag And File's Search function allows you to locate a directory or a file by typing its name. 

When the directory pane is active, Drag And File will search the current drive to find a 
directory which matches the letters you type. When the file pane is active, the program 
searches for a file name match in the current directory.

Search window

To find a file or directory by name:

1. In the main window, select the directory or file pane using the mouse or the tab key.

2. Type the first letters of the directory or file you want to locate.

Typed letters appear in the search window in the left lower corner of the drive window, just beneath 
the directory pane. Drag And File highlights the directory or file which most closely matches the 
letters you type. 



File Menu
Use commands in the File menu to perform the most common functions used to manage your
files an directories.

In the graphic below, click on any command to see more information on the command.



Shortcut: F8

Note:      For keyboard selection and deselection of options in the dialog box, press 
Alt and the underlined letter of the option.    

Use the Copy command to copy a single highlighted or one or more tagged files or 
directories, depending on the active pane, from one location to another, leaving a copy of the 
original file.

Use the Move command to move the single highlighted or one or more tagged files or 
directories from one location to another.

Select Copy or Move by checking the appropriate button.

For the Copy command, choose whether to suppress the Duplicate File Warning. Confirm 
whether the Copy/Move is for all windows or for one window.

Type in the location to which the file is to be copied, or choose Browse to select a directory 
from a list.



Shortcut: F7

Note:     For keyboard selection and deselection of options in the dialog box, press Alt
and the underlined letter of the option.    

Use the Copy command to copy a single highlighted or one or more tagged files or 
directories, depending on the active pane, from one location to another, leaving a copy of the 
original file.

Use the Move command to move the single highlighted or one or more tagged files or 
directories from one location to another.

Select Copy or Move by checking the appropriate button.

For the Copy command, choose whether to suppress the Duplicate File Warning. Confirm 
whether the Copy/Move is for all windows or for one window.

Type in the location to which the file is to be copied, or choose Browse to select a directory 
from a list.



Keyboard: Del

Use the Delete command to delete a single highlighted or one or more tagged files or 
directories. 

The dialog box which appears when you invoke this command is the only confirmation you 
will see of this operation.



Use the Undelete command to open the Microsoft Undelete dialog box. 

For additional information on using Undelete, see the Help menu in the Undelete dialog box.



Keyboard: Enter

Use the Launch command to run or activate the highlighted file or tagged files, or to run the 
program associated with the file type and load the file.

If no association exists for the type of file you have selected, Drag And File opens a dialog 
box in which you may record an association for this type of file.



Keyboard: Alt+M

Use the Make Directory command to create a new directory as a subdirectory of the currently 
highlighted directory.



Keyboard: Alt+Enter

Use the File Attributes command to open the Attributes dialog box.

File attributes dialog box

Use choices in this box to assign or remove attributes which are useful in managing files, and
which the operating system sometimes assignes automatically. MS-DOS uses four attributes 
and a null condition:

Archive

Read 
Only

System

Hidden

No 
Attributes

The Archive attribute is assigned by DOS to a file which has changed after being backed up.

Read only prevents a file from being edited or deleted.

System files, designated by DOS, contain information about hardware and system configuration. 
They cannot normally be deleted or changed.

Hidden prevents a file from being included in a DOS directory listing. Drag and File, however, 
does include hidden files in its display of files in a directory.    

No Attributes specifically eliminates any attributes assigned to a file.





Use the Associate command to associate a program file with a file of a particualar type 
identified by its three-letter extension.

For example, files ending in .TXT are normally text files and would be associated with an 
editor such as Windows Notepad or Norton's Desktop Editor.

To record an association:

1. Click on the Associate option from the File menu.

2. Choose the program file from those displayed.

-OR-

Click on Browse to select a program file from another directory.

3. Click OK to close the window and record your choices.



Use the Multi Associate command to associate more than one program with filenames of a 
specified extension. If you want to choose among different word processors to edit files with a
.TXT extension, for example, you would use this command to list those word processors.

When you double click on a file with such an extension, Drag And File opens a dialog box 
which allows you to choose one of the designated programs associated with this filename 
extension.

To record mutiple associations:

1. Click on the Multi Associate option from the File menu.

2. Type the full pathname (including drive, directory, and filename) of the new program.

-OR-

Click on Browse to select a program file from another directory.

3. Click Add to add the program to those displayed in the current associations window.

4. Click OK to close the window and record your choices.



Keyboard: Ctrl+Enter

Use the List All Files command to open a files-only window which contains an alpha-ordered 
list of all files on the drives you select.

To list all files:

1. Select this command to open the drive selection window.

2. Select the drives containing the files you wish to list. 

Ctrl+LClick or Shift+LClick toggles drive selection.

3. Click OK to open the file list window.



Choose the Quit command to close Drag And File.



Use the Close All Windows command to close all open Drag And File windows, including the 
window from which the command is selected.

The DF Drivebar icon is not affected by this command.



Sort Menu
Use commands in this menu to arrange the order of the files in the file window.

In the graphic below, click on any command to see more information on that command.



Keyboard: Ctrl+Shift+E

The by Extension command sorts files by the three-letter filename extension, in alpha order of
extension, and by alpha order within each group of files of the same extension.



Keyboard: Ctrl+Shift+F

The by Filename command sorts the file list by filename in alpha order.



Keyboard: Ctrl+Shift+D

The by Date command sorts the file list in ascending order of date, from earliest to latest.



Keyboard: Ctrl+Shift+S

The by Size command sorts the file list by size, in ascending order, from the smallest to the 
largest.



Keyboard: Ctrl+Shift+U

The Unsorted command resets the file list to the original order before other sort commands 
were applied.



The Save command saves the current sort order as the default.



Tag Menu
Use commands in the Tag menu to tag and untag individual files and directories, and groups 
of files and directories.

In the graphic below, click on any command to see procedures or additional information about
that command.

Note: Tagging and untagging is normally faster using the hotkeys or the mouse 
directly, rather than using a drop down menu, which adds an extra step to the 
process.



Keyboard: Right Arrow

The Tag command tags with a red arrowhead the file or directory currently highlighted.



Keyboard: Left Arrow

The Untag command untags the tagged file or directory currently highlighted.



Keyboard: Ctrl+Left Arrow

The Tag All command tags all entries in the currently active window, directory or file.



Keyboard: Ctrl+Right Arrow

The Untag All command untags all tagged files or directories in the currently active window.



Keyboard: Ctrl+Shift+B

The Tag Branch command tags a selected directory and all of its branches.



Keyboard: Ctrl+Shift+L

The Tag Files command opens a File specification dialog box, which allows you to specify the
name, types, and attributes of files to be tagged.

Tag files dialog box



Keyboard: Ctrl+Shift+R

The Retag command resets dots to tags. 

After a tagged group of files has been copied, the tag changes to a small red dot. Use this 
command to reset the red dot back to a tag, making possible additional actions on these files 
as a group. 



Options Menu
Use commands on the Options menu to configure Drag And File.

In the graphic below, click on any command to see procedures or additional information about
the command.



Use the Fonts command to open the Font selection dialog box, which allows you to choose 
one of the Windows installed fonts to use for directory and file listings.



Use the Settings command to open the Settings dialog box. Choices in this dialog box allow 
you to: 

Manage overwrite warnings 

Enable 
operations on multiple windows 

Choose
viewer options and window appearance 

Specify 
a text editor

Settings dialog box



Actions Menu
The Actions menu offers commands which allow you to work with the files and directories you
select.

In the graphic below, click on any command to see procedures or additional information about
that command.



Keyboard: Alt+L

Use the Filter command to open a file specification dialog box, which allows you to specify 
the name, types, and attributes of files to appear in the file window.

File specification dialog box

Use the
filename field to specify a name, part of a name, files of certain extensions. Wildcards !, *, and ? are 
accepted. 

Specify 
attributes to limit the file listing. There are four DOS file attributes and a null condition.

The Archive attribute is assigned by DOS to a file which has changed after being backed up.

Read only prevents a file from being edited or deleted.

System files, designated by DOS, contain information about hardware and system configuration. 
They cannot normally be deleted or changed.

Hidden prevents a file from being included in a DOS directory listing. Drag and File, however, 
does include hidden files in its display of files in a directory.    

No Attributes specifically eliminates any attributes assigned to a file.



Keyboard: Alt+V

Use the View command to open a Drag And View window. 

The window displays the contents of the currently highlighted file in a format Drag And File 
chooses to match the file type. If no match is found, a hexadecimal or an ASCII view opens, 
depending on the viewable content of the file.



Use the approriate Print command to print a directory or a file list. and to change the selection
of your Windows default printer.

Print dialog box
The Print command also allows you to print a directory or a file list as a file. 



The Edit command allows you to activate the text editor specified in the Options/Settings 
dialog box and load the highlighted file into the editor.

If no association exists for the file type highlighted when you invoke this command, a dialog 
box opens to allow you to establish an association.



Window Menu
The Window menu offers commands which allow you to manage the windows of Drag And 
File.

In the graphic below click on any command to see procedures or additional information about 
that command.



Use the New Window command to open a new Drag And File window.

The drive displayed in the current window appears in the new window. 



Keyboard: Shift+F5

Use the Cascade command to arrange the open Drag And File windows on the screen in an 
overlapping manner so the title bars are visible.



Keyboard: Shift+F4

Use the Tile command to arrange the open Drag And File windows on the screen so that 
each is wholly visible.



Keyboard: F5

Use the Refresh drive command to update the listing of directories in the left pane of the 
window.



Keyboard: F4

Use the Refresh files command to update the listing of files in the right pane of the window.



Tools Menu
The Tools menu is an extension menu. If you are using MS-DOS v. 6.0 or higher, this menu 
choice is installed on Drag And File's menu bar by DOS. If you are using a lower version of 
DOS you will not see this menu.

Other programs (like Stacker for WIndows) may also install extension menus on the Drag And
File menu bar. 

The Dos Tools menu offers you direct access to three DOS file management tools: Backup, 
AntiVirus, and DoubleSpace.

Related Topics:
Backup (Tools Menu)
Antivirus (Tools Menu)
DoubleSpace Info (Tools Menu)



Backup (Tools Menu)
Use the Backup command to access the Microsoft Backup for Windows dialog box. 



Antivirus (Tools Menu)
Use the AntiVirus command to access the Microsoft AntiVirus for Windows dialog box.



DoubleSpace Info (Tools Menu)
Use the DoubleSpace command to access the Microsoft DoubleSpace dialog box.

Note:     If you are using another disk compression utility, such as Stacker, Microsoft
DoubleSpace incorrectly reports that your drive is not compressed.



Fmlaunch Menu
In the graphic below, click on any command to see procedures or additional information about
that command.

Fileman Launcher loads itself automatically into the Drag And File menu bar.

To prevent Fmlaunch from loading in the menu bar:

Select 
the Setup program from the Drag And File group in Program Manager and deselect Fileman Launcher.

OR-
1. Open a text editor, like Windows Notepad. 
2. Open WIN.INI from the Windows directory.
3. Under the heading    [addons] locate the line:

FMLaunchDLL=C:\directory\FML.DLL
where directory is the name of the directory where Fileman Launcher is located.

4. Place several semicolons in front of the line:
;;;FMLaunchDLL=C:\directory\FML.DLL

Fmlaunch will no longer appear in the menu bar.



Use the Zip files command to open the Drag and Zip dialog box to run PKZIP on the 
highlighted file or on one or more tagged files.



Use the View files command to open a Drag And View window to display the contents of the 
highlighted file.

If several files are tagged, the Drag And View toolbar includes arrow buttons which allow you 
to cycle through views of the tagged files.



Use the Auto view command to load the selected file in an open Drag And View window 
automatically.

In order for this option to function, check the Open view window if necessary option 
in the Settings dialog box of the Options menu.



Use the Run or Quit Programs commands to activate or close the auxiliary programs that 
work with Drag And File to help you manage files. 

These programs include Drag And View, Drag and Zip, and any other programs you add to 
the list.



Use the Modify Program List command to manage the auxiliary programs that work with Drag
And File.

At a minimum, those programs include Drag and Zip and Drag And View. Other programs 
may be added, up to a total of ten.

Selecting the Modify Program List command opens the Fileman Launcher dialog box.

Note: If the Show as icon button on the right side of the box is not checked, several other options in 
the box are not available.

Program #n
Displays the pathname of the program. If you are adding a new program, type in the full 
pathname, including drive and directory.

Run with File Manager
Check this box if you want this program to load and run automatically when you open Drag 
And File.

Visible with File Manager
Check this box if you want the program icon to be visible whenever Drag And File is running 
and visible. This choice is only available when Show as icon button is checked.

Remember icon position
Check this to cause the active icon to appear in the last position it occupied, rather than in the
default position in the lower left corner of the screen. This choice is available only when 
Show as icon button is checked.

Show as icon
Show normal
Show maximized
Select one of these buttons to determine whether the auxiliary program will appear on-screen
as an icon, in normal size, or maximized. Some programs may not respond to the screen 
sizing you select here.

Click OK to save your changes and exit. Click Cancel to exit without saving changes.



About Drag And View
Drag And View allows you to view the contents of a file or files without having to run the program that 
created them. 

Drag And View main window

Drag And View can view files created by popular word processors, databases, spreadsheets, and graphic 
programs. It uses viewers to display the files in their native format or a format close enough to your native
format that you can easily see what the file contains without unreadable formatting codes. You can view 
any file in ASCII or hexadecimal format. 

Drag And View offers these additional features:

Opens 
multiple windows to compare files

Searches for text in any file or a hexadecimal string in the Hex viewer

Goes to
any cell in a spreadsheet, any record in a database and any address in the hexadecimal view of a file

Views a
list of files viewed during the current session, and click on a listed file to re-view it



Viewing Files
Drag And View offers three ways to activate the file viewer:

Drag a 
highlighted file or several tagged files from Drag And File and drop on the minimized icon or on the 
already open Drag And View window.

Click on
the View button on the Drag And File toolbar to view a highlighted or tagged file.

Choose
View files from the Fmlaunch menu to view a highlighted or tagged file.

When more than one file is tagged, Drag And View views the first file and lists all files in the Filelist, up to 
20 files.

If Drag And View cannot open a viewer to display the file in its native format, it displays the file either in 
ASCII text or in hexadecimal format.



Drag And View Windows
After the first viewing window is open, the Drag And View icon remains active. Any file dropped on it will 
open another window. Clicking on the New Window button will also open a new window from the same 
Filelist.

Drag And View will open as many windows as your computer's memory will support. 

Any open Drag And View window can be closed, maximized or minimized to an icon.    Drop a file on a 
minimized Drag And View window to restore the window and display the file. 

To close all windows:

1. Click on the Drag And View icon to activate the system menu.

2. Select Close all windows.

Drag And View closes all windows but does not close the program. The icon remains visible.



Exiting Drag And View
Click on the active Drag And View icon to open the system menu. Choose Close from the menu.

On closing, Drag And View closes all open windows.



The Toolbar
Drag And View's main window includes a toolbar which offers one-click access to the most useful 
functions. 

Related Topics:
Launch
New
Goto
Find
Last, Next
Play



Launch
The Launch button runs the program associated with the file    type currently displayed.    

The Associate... command from the File menu of Drag And File specifies programs to associate with 
filename extensions. If the file type currently displayed has an associated extension, Drag And View will 
launch that program and load the file. If association is lacking, Drag And View opens a dialog box which 
allows you to establish an association.

If the file you are viewing is an executable program, Drag And View will run it when you choose this 
command.



New
The New Window button opens a new window with the same file list as the current window.    

Choose this command to view the same files in two or more windows.    Arrange these windows to view 
different parts of the same file or another file side by side.    Drag And View supports as many open 
windows as your computer's memory will sustain.



Goto
For database files, the Goto button opens a dialog box to specify a record to view.

For spreadsheet files, the Goto button opens a dialog box to specify a cell to view.

In the Hex viewer, the Goto button opens a dialog box to specify a hexadecimal offset for the viewer to 
show.

For all other file types, this button is inactive.



Find
The Find button opens a dialog box which allows you to specify a text string to search for. Choose OK to 
find the first match. Choose OK again to find each subsequent match.

The search can be case sensitive in all viewers except the Hex viewer. In the Hex viewer you can search 
in ASCIIas well as hexadecimal format.

This button is inactive for graphic file types. 



Last, Next
The Last and Next buttons allow you to scroll through the files in the Filelist.    These buttons are active 
only when the Filelist contains more than one file.



Play
The Play button is active when the current file being viewed is a Windows sound file with a .WAV 
extension.    

Drag And View will play the WAV file if you have a sound driver installed.    Choose the Play button to hear
the file again.



File Menu
Open (File Menu)
Exit (File Menu)
Word Wrap (File Menu)



Open (File Menu)
Use the Open command to open a new file in the current window.    

If there is a special file viewer for the file, it will be shown in its native format.    Otherwise, it will be shown 
with either the ASCIIviewer (if the file is made up chiefly of readable characters) or the Hex viewer.

The name of the file will be added to the top of the Filelist displayed on the Filelist menu.



Exit (File Menu)
Use the Exit command to close the current window.

Note that this command does not close the program. To close the program, use the System menu which 
is available by clicking on the program icon.



Word Wrap (File Menu)
The Word Wrap command    is a toggle which turns word wrap on or off when viewing ASCII files.    



View Menu
ASCII (View Menu)
Hex (View Menu)
Viewer (View Menu)



ASCII (View Menu)
Use this command to view a file in ASCII format.



Hex (View Menu)
Use this command to view a file in hexadecimal format.    The Hex viewer displays a file as both a series 
of hexadecimal (base 16) numbers and ASCII characters.



Viewer (View Menu)
Use this command to view a file in its native format    (using one of Drag And View's viewers) after viewing
the file in either ASCII or hexadecimal format.



Options Menu
Fonts (Options Menu)
Settings (Options Menu)



Fonts (Options Menu)
The Fonts command opens a dialog box to choose a font for the file viewers.    The specified font applies 
to all viewers' display text except the Hexadecimal viewer.



Settings (Options Menu)
The Settings command opens a dialog box which offers choices to control the appearance of the Drag 
And View active icon, file viewing windows.



Filelist Menu

Filelist (Filelist Menu)
The Filelist command displays the names of files that have been dragged to the open window or opened 
from the file menu in the current session of Drag And View.    The current file has a check before the 
name.    Highlighting another file and pressing Enter or clicking on another file name will display that file.



System Menu
Open the system menu by clicking on the active icon.

Related Topics:
Settings (System Menu)
Close All Windows (System Menu)
Close (System Menu)



Settings (System Menu)
The Settings command opens a dialog box which offers choices to control the appearance of the Drag 
And View active icon and file viewing windows.



Close All Windows (System Menu)
The Close All Windows command closes all the currently open Drag And View windows.    The command 
does not close the program, and the icon remains.



Close (System Menu)
The Close command exits the Drag And View program and closes all open Drag And View windows.



About Drag And Zip
Drag And Zip is a utility that brings drag and drop ease to file compression using the PKZIP compression 
program from PKWARE, Inc., or the LHA compression routine. You can also make self-extracting 
archives.

Drag And Zip dialog box

Drag And Zip allows you to compress files by dragging them from the file list and dropping them on the 
active Drag And Zip icon. Drag and Zip opens a dialog box with fields for you to enter the name of the 
archive file and a path for its location. Drag And Zip also allow you to drag and zip subdirectories.

Drag And Zip is compatible with PKZIP versions 1.1,    2.04g, and later. Any other versions of PKZIP may 
not work properly.    To use Drag And Zip to build and extract LZH files, you must have a copy of 
LHA.EXE.    Drag and Zip will not work with LHARC.EXE.

Drag And Zip's viewer, Zip View, allows you to display a list of the files contained in the compressed file. 
Listed files can then be selected by highlighting a single file or tagging one or more. You may perform a 
variety of operations on the selected files, including:

Extract 

Delete

Temporarily extract to a unique program group for further examination

Convert
to a self-extracting file (if you have ZIP2EXE.EXE on your system)

Run or 
load to an associated program

Modify 
and replace or restore



Scan 
for viruses    



PKZIP version options
Drag And Zip works with PKZIP versions 1.1 and 2.04. Each version offers different options for managing 
and storing compressed files.

Related Topics:
PKZIP 1.1 options
PKZIP 2.04 options



PKZIP 1.1 options
To zip files with PKZIP 1.1:

1. Drag and drop files or directories on the Drag And Zip active icon. 

The PKZIP 1.1 dialog box opens. 

2. Select a compression option.

Shorter time yields larger files; slower time produces maximum compression.

3. Select filename storage options:

The Zip subdirectories option will store all the files in the directory branch, including 
subdirectories.

The Store pathnames in subdirectories option will save and store only the pathnames of files in
the subdirectories of the chosen files, not of files in the main directory.

The Store all pathnames option saves all pathnames of all files selected for zipping.

Note:    Drag And File allows you to drag an entire branch from the directory tree. If you drag and zip a 
whole branch, deselect the Zip subdirectories option under Browse Arguments to avoid zipping the 
subdirectories twice.

4. Click on OK to close the PKZIP dialog box and begin the compression routine.

6. When PKZIP displays an OK button in the DOS box, click OK to close the box.



PKZIP 2.04 options
To zip files with PKZIP 2.04:

1. Drag and drop files or directories on the Drag And Zip active icon. 

The PKZIP 2.04 dialog box opens. 

2. Fill in the open fields.

Zip filename:    The name of the file resulting from compression.

Output directory:    The path where the file will be stored.

Command line arguments:    These codes control how PKZIP handles file compression.

Note:  Rather than enter arguments on the command line, most users should click the Browse 
Arguments button to display several option fields (see below). Make your choices and let PKZIP 
translate them into argument codes.

3. Click on Browse Arguments.

The Browse Arguments dialog box displays.

4. Choose appropriate selections, as follows.

Compression options:  Choices here balance speed against size. The faster the compression,
the larger the zip file.

Span multiple disks:  Check this option if you anticipate the zipped file will be larger than the 
capacity of a single piece of media. Selecting multiple disks enables the format options field.

Arguments: 
The Zip subdirectories option will store all the files in the directory branch, including 
subdirectories.

The Store pathnames in subdirectories option will save and store only the pathnames of
files in the subdirectories of the chosen files, not of files in the main directory.

The Store all pathnames option saves all pathnames of all files selected for zipping.

Version 2.04 Compatibility: These six checkboxes represent system options that may 
increase PKZIP's speed. Not all of the options may be compatible with your hardware configuration.
We suggest you turn them on one by one to achieve the best combination of speed and reliability.

5. Click on OK to close the Browse Arguments dialog box, and again to close the PKZIP dialog box 
and begin the compression routine.

6. When PKZIP displays an OK button in the DOS box, click OK to close the box.



Drag And Zip Settings
To change Drag And Zip settings:

1. Click on the active Drag And Zip icon.

2. Choose Settings from the pop-up menu.

The Drag And Zip Settings dialog box appears. 

4. Fill in the options as described below.

PKZIP dialog box
Icon always visible
This option makes Drag And Zip's icon visible at all times.    (If Fileman Launcher is running, it will 
automatically make the Drag And Zip icon visible.)

Icon stays where last put
This option causes Drag And Zip to remember and reuse its last icon position.    (Fileman Launcher does 
this automatically.)

PKZIP version 2 or greater
Check this statement if it is true; do not check it if you are running any version of PKZIP earlier than 
version 2.0 Drag And Zip passes switches and commands to PKZIP and PKUNZIP, which depend on this 
information. 

Output directory
Accept one of the two default directories (the current directory, or the directory from which you dragged 
files to be zipped) or type in another directory name.

PKZIP/PKUNZIP location 
LHA location
Enter the drive and directory where your copies of PKZIP.EXE, PKUNZIP.exe, and LHA.EXE are kept.

Icon caption
Enter text to use as a caption benath the Drag And Zip icon when it is an active icon. A blank field will 
produce a blank line under the active icon.



About Zip View
Zip View is a file viewing utility that works with Drag And File.

Zip View allows you to

Display 
a list of files contained within an archived file

Delete 
and run files

Extract 
files singly or in groups from a zip archive

Make 
compressed files self-extracting (if ZIP2EXE.EXE is present on your system)

Zip View main window



Selecting Zip files to examine
Zip View offers three ways to identify a zipped file or files to view.

Note: These methods depend on your having allowed the setup program to record an association 
between .ZIP files and Zip View. If you have not done so, record the association before proceeding. If 
necessary, consult Microsoft Windows Users' Guide for information on associating files.

Double 
click on the file in the filelist of any file manager that supports drag and drop.

Highlight the file and drag and drop it on the active Zip View icon or on the open Zip View window.

Select 
Open from the Zip View File menu, and choose the file you want to view.

The Zip View window opens, showing the contents of the zipped file. In addition, the window displays file 
names, file sizes, date and time files were saved,    and the total number of files and their collective size.

Related Topics:
Tagging/Highlighting Listed Files



Tagging/Highlighting Listed Files
The files included in a zipped file displayed in Zip View can be highlighted one by one or tagged as a 
group.

To highlight a file:

Click on
the file

Start 
typing the filename. Zip View will display your typing in the finder window. The highlight will move to the 
file in the filelist which most closely matches the letters you type.

To tag a file:

Ctrl+LButton click on a file

RButton click on a file

Press 
the spacebar when the file is highlighted

Press 
the right arrow key when the file is highlighted

Use the same procedure to untag tagged files one by one.

To tag or untag all files:

Ctrl+right arrow key to tag all files

Ctrl+left
arrow key to untag all files



Zip View Toolbar
The toolbar includes single click buttons which represent the most frequently used actions.

View Keyboard:    Alt-V
Use this button to cause Zip View to extract the file from its compressed archive,    load a file viewer and 
display the contents of the file. (To adjust the display, see options in the Settings menu.)

Delete Keyboard:    Alt-D
Press this button to delete any highlighted or tagged files.

Launch Keyboard:    Alt-L
Press the Launch button to extract any file from the highlighted zip file and, depending on the nature of 
the file, do the following:

If it is a 
program, run it 

-OR-

If it is a 
data or graphic file, run its associated program and load the file.    If no program association exists for the 
file, you will be prompted to choose one.

Extract
Press the Extract button to open a dialog box to specify:

Which 
files (tagged, highlighted, or all) to extract

The 
directory in which to store the extracted files

If the specified directory does not exist, Zip View will ask if you wish to create one.

In addition, press the Browse Arguments button to open a second dialog box where you can specify:

Create 
directories stored in the zip file (if the file was stored with this information)

Overwrite existing files and suppress the default overwrite warning message

Enable 
up to four arguments which may increase compression speed

If you have highlighted an LZH file for extraction, the dialog box is similar to that for zipped files, but 
presents fewer choices.

Scan
Press the Scan button to run a virus scanning program if you have one installed. 

Zip View must be able to pass arguments to the scan program in order to laod and run it. DOS-based 
programs normally run this way, but few Windows-based programs do. If yuor scanning program is 
Windows-based, Zip View may not be able to run it successfully.

Check Out
Press the Check Out button to create a Program Manager group, temporarily extract the highlighted or 
tagged files and place them as items in the group.



The Check Out feature allows you to run a program quickly. The procedure also includes a virus scan as 
an option before running the program.



Zip View Menus
Open (File Menu)
About (File Menu)
Exit (File Menu)
Sort ( Main Menu Bar)
Make EXE (Options Menu)
Convert to ZIP/LZH (Options Menu)
Fonts (Options Menu)
Settings (Options Menu)



Open (File Menu)
Use the Open command to list the files compressed in a zip file you select by browsing the directory tree 
or by typing in a filename.

This technique is especially useful to see the files archived in a self-extracting zip file which cannot be list-
viewed by double-clicking on it. 



About (File Menu)
Choose the About command to open a box with information about the version of Drag And Zip, and the 
address and telephone number of Canyon Software.



Exit (File Menu)
Select the Exit command to quit Zip View.



Sort ( Main Menu Bar)
Use the Sort command to sort the listing of files in a zip file by Filename, Extension, Date and Time, or 
Size.    You can also save the sort as a default.



Make EXE (Options Menu)
Choose the Make EXE command to make a highlighted or tagged files self-extracting.

Note: This action is available only if you 
have ZIP2EXE.EXE from PKWARE, Inc. 
installed in the same directory with your 
copies of PKZIP and PKUNZIP.



Convert to ZIP/LZH (Options Menu)
Use the Convert to ZIP/LZH command to convert a ZIP file to an LZH    file and an LZH file to a ZIP file.    

In a dialog box you may change the filename and the destination directory.    To convert a ZIP file to an 
LZH file requires copies of PKUNZIP and LHA.    To convert an LZH file to a ZIP file requires copies of 
LHA and PKZIP.



Fonts (Options Menu)
Use the Fonts command to open a standard Windows 3.1 font dialog box from which you can change the 
default font in Zip View.



Settings (Options Menu)
Use the Settings command to set preferences and defaults for Zip View.

Output directory
Use this option to choose the default output directory to store files you unzip. Two choices are available:

Current
Directory - the directory in which the file you are currently viewing resides

Previous Zip Directory - the last directory that you extracted files to

Display options
Use these options to choose information ZipView will show in the file display.    

Normally, any stored path information appears.    But select Show CRC to show CRC information 
instead. Your choice here becomes the default.

PKZIP version 2 or greater
Check this statement if it is true; do not check it if you are running any version of PKZIP earlier than 
version 2.04g. Drag And Zip passes switches and commands to PKZIP and UNZIP which depend on this 
information. 

PKZIP/PKUNZIP location 
LHA location
Enter the drive and directory where your copies of PKZIP.EXE, PKUNZIP.EXE, and LHA.EXE are kept.

Anti-Virus
Enter the path and the name of the antivirus program for Zip View to use when you request a virus scan.   

Enter commands ("arguments") for ZipView to pass to the scanning program to make it work.    

Put *.* where you want Zip View to substitute the drive and directory of the files that you want 
scanned.

Viewing Program
Enter the directory and the filename of the file viewer. The default entry is for Drag And View.




